Описание встроенного языка системы 1С Предприятие


Зарезервированные слова


Приведенные далее ключевые слова являются зарезервированными и не могут использоваться в качестве создаваемых имен переменных и объявляе­мых процедур и функций. В данном варианте языка каждое из ключевых слов имеет два представления — русское и английское. Английское представление является традиционным для языков программирования. Ключевые слова в русском и английском представлении могут свободно смешиваться в одном исходном тексте. Регистр букв ключевых слов не имеет значения. Ниже приведен список ключевых слов в обоих вариантах представления.

Если

If

He

Not

Дата

Date

Тогда

Then

Знач

Val

Формат

Format

ИначеЕсли

Elsif

СтрДлина

StrLen

Разм

Dim

Иначе

Else

СокрЛ

TrimL

Вопрос

Do Query Box

КонецЕсли

Endlf

СокрП

TrimR

Контекст

Context

Цикл

Do

Лев

Left

Перем

Var

Для

For

Прав

Right

Перейти

Goto

По

To

Сред

Mid

Возврат

Return

Пока

While

Цел

Int

Продолжить

Continue

Функция

Function

Окр

Round

Прервать

Break

КонецПроцедуры

EndProcedure

Число

Number

И

And

КонецФункции

EndFunction

Строка

String

Или

Or

Предупреждение

DoMessageBox

КонецЦикла

EndDo

Процедура

Procedure




Начало  Назад  Вперед



Книжный магазин