Описание встроенного языка системы 1С Предприятие


ЗаписьУдалена


Возвращает значение флага удаления текущей записи.

Синтаксис:

ЗаписьУдалена()

Англоязычный синоним:

RecDeleted

Возвращаемое значение:

Число: 1 — запись удалена; 0 — запись не удалена.

Описание:

Метод ЗаписьУдалена возвращает значение флага удаления текущей за­писи.

Пример:

Процедура Восст3ап()

   ТекРежим = ДБФ.ПоказыватьУдаленные(1);

   ДБФ.Первая(};

   Пока 1 = 1 Цикл

      Если ДБФ.ЗаписьУдалена() = 1 Тогда

         ДБФ.Восстановить();

         ДБФ.Записать();

      КонецЕсли;

      Если ДБФ.Следующая() = 0 Тогда

         ДБФ.ПоказыватьУдаленные(ТекРежим);

         Возврат;

      КонецЕсли;

   КонецЦикла;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин