Описание встроенного языка системы 1С Предприятие


ЗаписатьПроводки


Записать в информационную базу уже добавленные и заполненные проводки операции.

Синтаксис:

ЗаписатьПроводки()

Англоязычный синоним:

WriteEntries

Описание:

Метод ЗаписатьПроводки выполняет запись в информационную базу уже добавленных и заполненных проводок операции. Метод может использоваться только для атрибута «Операция» документа в момент проведения (в процедуре ОбработкаПроведения). При этом происходит обновление бухгалтерских итогов. Это позволяет при проведении документа обращаться к бухгалтерским итогам уже измененным проводками, записанными этим документом. После выполнения метода ЗаписатьПроводки и до окончания процедуры ОбработкаПроведение уже невозможно изменять или удалять проводки, до­бавленные до вызова этого метода.

Данный метод имеет смысл использовать, только в том случае, если сущест­вует необходимость обращения к итогам, измененным проводками записывае­мой операции.

Замечание. При записи сложной проводки, если у главной корреспонденции сложной проводки не указана сумма (равна 0), то она автоматически вы­числяется на основании подчиненных корреспонденции.

Пример:

Процедура СписаниеСчетаНаСч20(Счт)

   // создаем и формируем проводки

КонецПроцедуры

Процедура СписаниеСчета20На40()

   // создаем и формируем проводки

КонецПроцедуры

Процедура ОбработкаПроведения()

   Сч20 = СчетПоКоду("20");

   Cч40 = CчeтПoKoдy("40");

   СписаниеСчетаНаСч20(СчетПоКоду("25"));

   СписаниеСчетаНаСч20(СчетПоКоду("26"));

   Операция.ЗаписатьПроводки();

   СписаниеСчета20На40();

   Операция.Содержание = "Закрытие фин. результатов за " +

                         Формат(ДатаДок, "Д ММММГГГГ");

   Операция.Записать();

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин