Описание встроенного языка системы 1С Предприятие


Закладки


Объект типа «СписокЗначений», содержащий описания закладок те­кущей формы.

Синтаксис:

Закладки

Англоязычный синоним:

TabCtrl

Описание:

Атрибут объекта «Форма» Закладки представляет собой объект типа «Спи­сокЗначений», содержащий описания закладок текущей формы. Данный атри­бут предоставляет возможность программно манипулировать порядком и на­званиями закладок формы. В тексте программного модуля через точку после имени объекта «Форма» можно вызвать атрибут «Закладки», а далее через точ­ку можно вызывать методы управления закладками как объектом типа «Спи­сокЗначений».

Доступ к данному атрибуту возможен только в контексте Модуля формы после применения метода ИспользоватьЗакладки.

Пример:

Процедура ОбработкаКлиектов()

   Если ФлагФранчайзи = 1 Тогда

      Если Форма.Закладки.НайтиЗначение(2) = 0 Тогда

         Форма.Закладки.ДобавитьЗначение(2, "Поставщики");

      КонецЕсли;

   Иначе

      Позиция = Форма.Закладки.НайтиЗначение(2);

      Если Позиция > 0 Тогда

         Форма.Закладки.УдалитьЗначение(Позиция);

      КонецЕсли;

   КонецЕсли;

   форма.Закладки.Сортировать();

КонецПроцедуры

См. также: ИспользоватьЗакладки, ПриВыбореЗакладки, «Работа со СпискомЗначений»




Начало  Назад  Вперед



Книжный магазин