Описание встроенного языка системы 1С Предприятие


ВывестиСекцию - часть 2


Пока 3апросКат.Группировка("Ктг") = 1 Цикл

   Таб.ПрисоединитьСекцию("КолонТитул|Осн2");

КонецЦикла;

Таб.ПрисоединитьСекцию("КолонТитул|ДокументВерт>");

Продолжать = 1;

Пока Запрос.Группировка("Пдр") = 1 Цикл

   // Заполнение полей

   Пдр Таб.ВывестиСекцию("Осн1|ДокументВерт<");

   Далее = 1;

   Пока Продолжать = 1 Цикл

      // Заполнение полей Ктг

      СлКат = ЗапросКат.Группировка("Ктг");

      Если Далее = 1 Тогда

         ОК = Запрос.Группировка("Ктг");

      КонецЕсли;

      Если СлКат = 0 Тогда

         Прервать;

      КонецЕсли;

      Если ЗапросКат.Ктг = Запрос.Ктг Тогда

         Таб.ПрисоединитьСекцию("Осн1|Осн2");

         Далее = 1;

      Иначе

         Таб.ПрисоединитьСекцию("Осн1|Пусто");

         Далее = 0;

      КонецЕсли;

   КонецЦикла;

   Таб.ПрисоединитьСекцию("Осн1|ДокументВерт>");

КонецЦикла;




Начало  Назад  Вперед



Книжный магазин