Описание встроенного языка системы 1С Предприятие


ВыполнитьРасчет


Выполнить расчет текущей записи журнала расчетов.

Синтаксис:

ВыполнитьРасчет()

Англоязычный синоним:

RunCalculate

Возвращаемое значение:

Числовое значение — 1, если расчет записи выполнен успешно, и 0 — в про­тивном случае (в том числе, при прерывании процедуры расчета пользователем путем нажатия клавиши <Esc>).

Описание:

Выполняет расчет текущей строки журнала расчетов.

Как правило, применяется в цикле, выполняющем перебор записей журнала расчетов при помощи метода ПолучитьЗапись. Работает точно так же, как и метод Рассчитать, но имеет возвращаемое значение. Применяется в том слу­чае, если при обработке в цикле записей журнала расчетов бывает необходимо прервать выполнение расчета.

Пример:

// процедура выполняет расчет по журналу Зарплата

Процедура Выполнить()

   ЖрнЗарплата.ВыбратьПериод{ЖрнЗарплата.НачалоТекущегоПериода());

   Пока ЖрнЗарплата.ПолучитьЗапись() > 0 Цикл

      Если Считать() = 1 Тогда

         Если ЖрнЗарплата.ВыполнитьРасчет()= 0 Тогда

            // прерываем процедуру, если расчет неудачен или

            // пользователь нажал Езс

            Прервать;

         КонецЕсли;

      КонецЕсли;

   КонецЦикла;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин