Описание встроенного языка системы 1С Предприятие


ВыбратьЗначения


Открыть выборку периодических значений по датам.

Синтаксис:

ВыбратьЗначения(<ДатаНачала>, <ДатаКонца>)

Англоязычный синоним:

Selectltems

Параметры:

<ДатаНачала>

Необязательный параметр. Выражение типа «да­та» — дата начала периода выборки периодиче­ских значений. Если параметр не задан, то выбор­ка начинается с самой ранней имеющейся даты.

<ДатаКонца>

Необязательный параметр. Выражение типа «да­та» — дата конца периода выборки периодических значений. Если параметр не задан, то выборка заканчивается самой последней имеющейся датой.

Возвращаемое значение:

Число: 1 — если вызов метода закончился успешно, 0 — если нет.

Описание:

Метод ВыбратьЗначения предоставляет возможность (открывает выбор­ку) выбирать периодические значения при помощи метода ПолучитьЗначение.

Дальнейшая выборка при помощи метода ПолучитьЗначение будет про­исходить среди периодических значений текущего объекта применения, задан­ного методом ИспользоватьОбъект.

Пример:

Процедура КурсыВалюты(КодВалюты)

   Вал = СоздатьОбъект("Справочник.Валюты");

   // Позиционируем созданный объект Вал по известному коду

   Вал.НайтиПоКоду(КодВалюты);

   Если Вал.Выбран() = 1 Тогда

      Доллар = Вал.ТекущийЭлемент();

   Иначе

      Предупреждение("Не найдена валюта!");

      Возврат;

   КонецЕсли;

   ПерВал = СоздатьОбъект("Периодический");

   ПерВал.ИспользоватьОбъект("Текуш_курс", Доллар);

   ПерВал.ОбратныйПорядок(1);

   ПерВал.ВыбратьЗначения();

   Пока ПерВал.ПолучитьЗначение() = 1 Цикл

      Сообщить("Курс: " + Строка(ПерВал.ДатаЗнач) + ПерВал.Значение);

   КонецЦикла;

КонецПроцедуры

См. также: ПолучитьЗначение, ИспользоватьОбъект




Начало  Назад  Вперед