Описание встроенного языка системы 1С Предприятие


ВыбратьЗаписиПоОбъекту


Выбрать записи, действующие в определенном временном интервале и принадлежащие одному объекту расчета.

Синтаксис:

ВыбратьЗаписиПоОбъекту(<Объект>, <Начало>, <Окончание>)

Англоязычный синоним:

SelectRecordsByObject

Параметры:

<Объект>

Объект расчета, записи которого выбираются.

<Начало>

Дата начала периода.

<Окончание>

Дата окончания периода.

Возвращаемое значение:

Число: 1 — если операция успешно выполнена и выборка не пуста, т. е. со­держит хотя бы одну запись; 0 — в противном случае.

Описание:

Метод открывает выборку записей журнала расчетов. Выбираются все запи­си, рассчитанные для объекта, заданного параметром <Объект>, период дейст­вия которых хоть на один день затрагивается тем периодом, который задан па­раметрами <Начало> и <Окончание>. Следовательно, метод ВыбратьЗаписиПоОбъекту отличается от ВыбратьЗаписи лишь тем, что в первом случае в выборку попадают записи по одному конкретному объекту расчета, а во втором — по всем объектам расчета.

Данный метод работает только для переменных, созданных функцией СоздатьОбъект.

Пример:

// Проходя по справочнику акционеров, проведем по некоторому

// условию полный расчет дивидендов

// Готовим справочник акционеров

Акционеры = СоздатьОбъект("Справочник.Акционеры");

Акционеры.ПорядокКодов();

Акционеры.ВыбратьЭлементы();

// Журнал расчетов дивидендов

ЖР = СоздатьОбъект("ЖурналРасчетов.Дивиденды");

// Начало и конец текущего периода

Нач = ЖР.НачалоТекущегоПериода();

Кон = ЖР.КонецТекущегоПериода();

Пока Акционеры.ПолучитьЭлемент() > 0 Цикл

   Если Акционеры.Статус = 2 Тогда

      ЖР.ВыбратьЗаписиПоОбъекту(Акционеры.ТекущийЭлемент(), , );

      Пока ЖР.ПолучитьЗапись() > 0 Цикл

         ЖР.Рассчитать();

      КонецЦикла;

   КонецЕсли;

КонецЦикла;

См. также: ВыбратьПериодПоОбъекту, ВыбратьЗаписи




Начало  Назад  Вперед



Книжный магазин