Описание встроенного языка системы 1С Предприятие


ВыбратьПоДокументу


Открыть выборку всех изменений периодических реквизитов спра­вочника, сделанных документом.

Синтаксис:

ВыбратьПоДокументу(<Документ>)

Англоязычный синоним:

SelectByDoc

Параметры:

<Документ>

Выражение со значением типа «документ».

Возвращаемое значение:

Число: 1 — если вызов метода закончился успешно, 0 — если нет.

Описание:

Метод ВыбратьПоДокументу предоставляет возможность (открывает вы­борку) выбирать все периодические значения (по всем справочникам и рекви­зитам), заданные в справочнике документом.

Дальнейшая выборка осуществляется при помощи метода ПолучитьЗначение. При использовании данного метода не используется (иг­норируется) установка объекта применения, задаваемая методом ИспользоватьОбъект.

См. также: УстановитьРеквизитСправочника, ТекущийОбъект, ТекущийРеквизит, ПолучитьЗначение

Пример:

Процедура ПечатьУстановокДокумента(Док)

   Если Док.Выбран() = 0 Тогда

      Возврат;

   КонецЕсли;

   Таб = СоздатьОбъект("Таблица");

   Таб.ИсходнаяТаблица("ПечатьИстории");

   Таб.ВывестиСекцию("Отчет" );

   Ист = СоздатьОбъект ("Периодический");

   Ист.ВыбратьПоДокументу(Док);

   Пока Ист.ПолучитьЗначение() = 1 Цикл

      Таб.ВывестиСекцию("Строка");

   КонецЦикла;

   Таб.Опции(0, 0, 0, 0);

   Таб.ТолькоПросмотр(1);

   Таб.Показать("Отчет");

КонецПроцедуры




Начало  Назад  Вперед