Описание встроенного языка системы 1С Предприятие


ВыбратьПериодПоОбъекту


Выбрать записи по одному объекту расчета, зарегистрированные в определенном расчетном периоде журнала расчетов.

Синтаксис:

ВыбратьПериодПоОбъекту(<Объект>, <Дата>)

Англоязычный синоним:

SelectPeriodByObject

Параметры:

<Объeкт>

Объект расчета, записи которого выбираются.

<Дaтa>

Дата, лежащая в выбираемом периоде.

Возвращаемое значение:

Число: 1 — если операция успешно выполнена и выборка не пуста, т. е. со­держит хотя бы одну запись; 0 — в противном случае.

Описание:

Метод открывает выборку записей журнала расчетов. Работает так же, как метод ВыбратьПериод, за исключением того, что выбираются все записи для того объекта расчета, который задан параметром <Объект>.

Данный метод работает только для переменных, созданных функцией СоздатьОбъект.

Пример:

*

Процедура Начислено(Сотрудник)

   Начисл = 0;

   ПН = 0;

   ЖрнЗарплата.ВыбратьПериодПоОбъекту (Сотрудник, ДатаАктуальности);

   Пока ЖрнЗарплата.ПолучитьЗапись() = 1 Цикл

      Если ЖрнЗарплата.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеНачисления)-1 Тогда

         Начисл = Рез + ЖрнЗарплата.Результат;

      ИначеЕсли ЖрнЗарплата.ВидРасч = ВидРасчета.ПодоходныйНалог

         Тогда ПН = ПН+ЖрнЗарплата.Результат;

      КонецЕсли;

   КонецЦикла;

КонецПроцедуры

*

// расчет начального сальдо

ЖрнЗарплата.ВыбратьПериодПоОбъекту(Сотрудник, НТП - 1);

Сальдо = 0;

Пока ЖрнЗарплата.ПолучитьЗапись() = 1 Цикл

   Если ЖрнЗарплата.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеУдержания) = 1 Тогда

      Сальдо = Сальдо-ЖрнЗарплата.Результат;

      // выплаты с деполнента и выплаты дивидендов — не считатем!

   ИначеЕсли ВыплатаЗрп(ЖрнЗарплата.ВидРасч, ЖрнЗарплата.Документ) = 1 Тогда

      Сальдо = Сальдо - ЖрнЗарплата.Результат;

   ИначеЕсли ЖрнЗарплата.ВидРасч.

                  ВходитВГруппу(ГруппаРасчетов.ПоложительноеСальдо) = 1 Тогда

      Сальдо = Сальдо + ЖрнЗарплата.Результат;

   КонецЕсли;

КонецЦикла;

Если Сальдо <> 0 Тогда

   ЖрнЗарплата.ЗаписатьРасчет(Сотрудник,

   ВидРасчета.НачальноеСальдо, НТП, КТП, Сальдо);

КонецЕсли;

См. также: методы ВыбратьПериод, ВыбратьтЗаписи, атрибут Объект




Начало  Назад  Вперед



Книжный магазин