Описание встроенного языка системы 1С Предприятие


ВыбратьДвижения


Выбрать все движения регистра по датам.

Синтаксис:

ВыбратьДвижения(<НачалоВыборки>, <КонецВыборки>, <ГрафаОтбора>)

Англоязычный синоним:

SelectActs

Параметры:

<НачалоВыборки>

Выражение типа дата, документ или позиция доку­мента, задающее начало временного интервала выбо­ра движений регистра.

<КонецВыборки>

Выражение типа дата, документ или позиция доку­мента задающее конец временного интервала выбора движений регистра.

<ГрафаОтбора>

Необязательный параметр. Строковое выражение — идентификатор графы отбора, как он задан в конфи­гураторе. Данный параметр устанавливает режим использования определенной графы отбора. "*" — автоматический выбор графы отбора. Пустая строка — не использовать графу отбора. По умолчанию устанавливается автоматический вы­бор графы отбора.

Описание:

Метод ВыбратьДвижения инициирует выбор всех движений регистра в указанном интервале дат. До вызова данной процедуры может быть установлен фильтр (см. УстановитьФильтр), ограничивающий выборку значений из регистра. Если <КонецВыборки> не указан или равен 0, то концом временно­го интервала выбора движений регистра считается ТА.

Собственно выбор первого и последующих движений регистра осуществля­ется функцией ПолучитьДвижение.

Пример:

Рег1 = СоздатьОбъект("Регистр.Взаиморасчеты");

Если Режим = "Подробно" Тогда

   Рег1.УстановитьФильтр(Клиент);

   Рег1.ВыбратьДвижения(ДатаНачало, );

   Пока Рег1.ПолучитьДвижение() > 0 Цикл

      Док = Рег1.ТекущийДокумент();

      Дв_Баз_Сум = Рег1.СуммаБазовая;

      Дв_Вал_Сум = Рег1.СуммаВалютная;

      Если Рег1.Расход = 1 Тогда

         Таб.ВывестиСекцию("Расход2");

      Иначе

         Таб.ВывестиСекцию("Приход2");

      КонецЕсли;

   КонецЦикла;

КонецЕсли;

См. также: ПолучитьДвижение




Начало  Назад  Вперед



Книжный магазин