Описание встроенного языка системы 1С Предприятие


ВыбранаПоДт, ВыбранаПоКт


ВыбранаПоДт — определение, выбран ли итог по дебету;

ВыбранаПоКт — определение, выбран ли итог по кредиту.

Синтаксис:

ВыбранаПоДт()

ВыбранаПоКт()

Англоязычный синоним:

SelectedByDt

SelectedByKt

Возвращаемое значение:

Число: 0 —данный итог по дебету(кредиту) не выбран; 1 —данный итог по дебету(кредиту) выбран.

Описание:

Данные функция используются при обходе результатов запроса с детализа­цией периода по операциям и проводкам. Они показывают для текущей опера­ции (проводки) попала ли она в запрос по дебетовой (кредитовой) корреспон­денции.

Пример:

БухИтоги.ВыполнитьЗапрос(Дата1, Дата2, "50", , , , "Проводки");

БухИтоги.ВыбратьСчета();

БухИтоги.ВыбратьПериоды();

КолПрих=0;

КолРасх=0;

Пока БухИтоги.ПолучитьПериод() = 1 Цикл

   Если БухИтоги.ВыбранаПоДт() = 1 Тогда

      КолПрих = КолПрих + 1;

   КонецЕсли;

   Если БухИтоги.ВыбранаПоКт() = 1 Тогда

      КолРасх = КолРасх + 1;

   КонецЕсли;

КонецЦикла;





Начало  Назад  Вперед



Книжный магазин