Описание встроенного языка системы 1С Предприятие


Выбран


Возвращает признак того, выбран конкретный вид расчета или нет.

Синтаксис:

Выбран()

Англоязычный синоним:

Selected

Возвращаемое значение:

Число: 1 — если конкретный вид расчета выбран; 0 в противном случае.

Описание:

Этот метод предназначен для определения, не является ли «пустым» значе­ние переменной или реквизита типа «ВидРасчета».

Вид расчета (в отличие от группы расчетов, например) в рамках описывае­мого встроенного языка — сохраняемый агрегатный тип данных, т. е. объекты этого типа могут сохраняться в информационной базе. Например, реквизиты справочника, документа или журнала расчетов, могут иметь тип «ВидРасчета» и, следовательно, хранить ссылки на конкретные виды расчетов. При этом час­то необходимо иметь возможность определить выбрано ли конкретное значение для реквизита (например, справочника или документа) этого типа.

Пример:

// Допл — объект типа "группа расчетов"

Допл = ГруппаРасчетов.Доплаты;

ЖЗ = СоздатьОбъект("ЖурналРасчетов.Зарплата");

// Док — ссылка на документ, имеющий реквизит Сотрудник

ЖЗ.ВыбратьЗаписиПоОбъекту(Док.Сотрудник);

Пока ЖЗ.ПолучитьЗапись() = 1 Цикл

   Если ЖЗ.ВидРасч.ВходитВГРуппу(Допл) = 1 Тогда

      // предполагается, что документы-основания этих

      // видов расчета имеют реквизит ВР

      Если ЖЗ.Документ.ВР.Выбран() = 0 Тогда

         Сообщить("Не указан конкретный вид расчета в документе!");

      КонецЕсли;

   КонецЕсли;

КонецЦикла;




Начало  Назад  Вперед