Описание встроенного языка системы 1С Предприятие


Выбран


Возвратить флаг выбора документа.

Синтаксис:

Выбран()

Англоязычный синоним:

Selected

Возвращаемое значение:

Числовое значение: 1 — если документ выбран, 0 — если документ не вы­бран.

Описание:

Метод Выбран позволяет проверить сам факт позиционирования объекта типа «документ».

Пример:

Док = СоздатьОбъект("Документ.ПрихНакл");

// позиционируем документ по номеру

Док.НайтиПоНомеру("1", 0);

Если Док.Выбран() = 1 Тогда

    // если документ найден

    // открываем выборку строк спецификации документа

    Док.ВыбратьСтроки();

    // цикл выбора строк спецификации документа

    Если Док.КоличествоСтрок() > 0 Тогда

       Пока Док.ПолучитьСтроку() = 1 Цикл

          Док.УдалитьСтроку();

       КонецЦикла;

    КонецЕсли;

КонецЕсли;




Начало  Назад  Вперед



Книжный магазин