Описание встроенного языка системы 1С Предприятие


ВвестиСтроку


Вызов диалога для ввода строки.

Синтаксис:

ВвестиСтроку(<Строка>, <Подсказка>, <ДлинаСтроки>, <Признак>, <Таймаут>)

Англоязычный синоним:

InputString

Параметры:

<Строка>

Имя переменной, ранее объявленной в программном модуле. В эту переменную будет помещено введенное строковое значение.

<Подсказка>

Текст заголовка окна диалога ввода. Может исполь­зоваться в качестве подсказки конечному пользовате­лю.

<ДлинаСтроки>

Числовое выражение — длина строки.

<Признак>

Необязательный параметр. Числовое выражение, если 0 — ввод простой строки без разделителей строк, если 1 — ввод многострочного текста с разделителя­ми строк. Значение по умолчанию — 0.

<Таймаут>

Необязательный параметр. Числовое выражение ин­тервала времени ожидания ответа в секундах, в тече­ние которого система будет ожидать ответа пользова­теля. Если данный параметр опущен или равен 0, то время ожидания бесконечно. Значение по умолчанию — 0.

Возвращаемое значение:

Числовое значение: 1 — если в диалоге нажата кнопка «ОК», 0 — если на­жата кнопка «Отмена»; -1 (минус единица) — если закончилось время ожида­ния ответа.

Описание:

Функция ВвестиСтроку выполняет вызов диалога для ввода строки.

Пример:

Процедура ВводКодовПродукции()

   Если Продукция.Вид = Перечисление.ВидПродукции.Наша Тогда

      НК = Код;

      Если ВвестиСтроку(НК, "Введите код продукции", 40, 1, 9) = 1 Тогда

         Koд = HK;

      КонецЕсли;

   Иначе

      Код = "";

      Возврат;

   КонецЕсли;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин