Описание встроенного языка системы 1С Предприятие


ВвестиДату


Вызов диалога для ввода даты.

Синтаксис:

ВвестиДату(<Дата>, <Подсказка>, <Таймаут>)

Англоязычный синоним:

InputDate

Параметры:

<Дата>

Имя переменной, ранее объявленной в про­граммном модуле. В эту переменную будет по­мещено введенное значение даты.

<Подсказка>

Текст заголовка окна диалога ввода. Может ис­пользоваться в качестве подсказки конечному пользователю.

<Таимаут>

Необязательный параметр. Числовое выражение ин­тервала времени ожидания ответа в секундах, в тече­ние которого система будет ожидать ответа пользова­теля. Если данный параметр опущен или равен 0, то время ожидания бесконечно. Значение по умолчанию — 0.

Возвращаемое значение:

Числовое значение: 1 — если в диалоге нажата кнопка «ОК»; 0 — если на­жата кнопка «Отмена»; -1 (минус единица) — если закончилось время ожида­ния ответа.

Описание:

Функция ВвестиДату выполняет вызов диалога для ввода даты.

Пример:

Процедура ВводДатыСсуды()

   Если ВидРасчета = ВидРасчета.БеспроцентнаяСсуда Тогда

      ДатаСсуды = Дата(0);

      Возврат;

   КонецЕсли;

   Если ДатаСсуды = Дата(0) Тогда

      ДатаСсуды = ДатаДок + 30;

   КонецЕсли;

   Д = ДатаСсуды;

   Если ВвестиДату(Д, "Введите дату ссуды") = 1 Тогда

      ДатаСсуды = Д;

   Иначе

      ВидРасчета = ВидРасчета.БеспроцентнаяСсуда;

   КонецЕсли;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин