Описание встроенного языка системы 1С Предприятие


ВНачале


Прочитать значение флага начала файла.

Синтаксис:

ВНачале()

Англоязычный синоним:

BOF

Возвращаемое значение:

Число: 1 — указатель в файле находится перед первой записью; 0 — начало файла не достигнуто.

Описание:

Метод ВНачале возвращает значение флага начала файла.

Пример:

Функция СреднСтоимПокупки()

   ДБФ.Последняя();

   Уплачено = 0;

   Записей = 0;

   Пока ДБФ.ВКонце() = 0 Цикл

      Уплачено = Уплачено + ДБФ.AMOUNT;

      Записей = Записей + 1;

      ДБФ.Следующая();

   КонецЦикла;

   Если Записей > 0 Тогда

      Уплачено = Уплачено / Записей;

   КонецЕсли;

   Возврат Уплачено;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин