Описание встроенного языка системы 1С Предприятие


ВКонце


Прочитать значение флага конца файла базы банных.

Синтаксис:

ВКонце()

Англоязычный синоним:

EOF

Возвращаемое значение:

Число: 1 — указатель в файле находится за последней записью; 0 — конец файла не достигнут.

Описание:

Метод ВКонце возвращает значение флага конца файла.

Пример:

Функция МаксимальнаяПокупка()

   ДБФ.Первая();

   Уплачено = 0;

   Пока ДБФ.Вконце() = 0 Цикл

      Если ДБФ.AMOUNT > Уплачено Тогда

         Уплачено = ДБФ.AMOUNT;

      КонецЕсли;

      ДБФ.Следующая();

   КонецЦикла;

   Возврат Уплачено;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин