Описание встроенного языка системы 1С Предприятие


ВидРасч


Вид расчета текущей записи журнала расчетов.

Синтаксис:

ВидРасч

Англоязычный синоним:

CalculKind

Описание:

Атрибут типа «ВидРасчета». Ссылка на конкретный вид расчета, алгоритм которого будет использован при вычислении результата данной записи журна­ла расчетов (акта расчета).

Атрибут ВидРасч предназначен только для чтения.

Пример:

// Перечисление в банк

Процедура ПровестиРасчет()

   // Процедура выполняется при проведении расчета

   // посчитаем сумму на руки

   НаРуки = 0;

   ЖР = СоздатьОбъект("ЖурналРасчетов.Зарплата");

   Пока ЖР.ПолучитьЗапись() = 1 Цикл

      // если строка журнала расчетов имеет вид расчета,

      // входящий в группу "Все начисления"

      Если ЖР.ВидРасч.ВходитВГруппу(Группа.ВсеНачислнения) Тогда

         НаРуки = НаРуки + ЖР.Результат;

         // ...или "Все удержания"

      ИначеЕсли ЖР.ВидРасч.ВходитВГруппу(Группа.ВсеУдержания) Тогда

         НаРуки = НаРуки - ЖР.Результат;

      КонецЕсли;

   КонецЦикла;

   Если Документ.Сумма <> 0 Тогда

      Результат = Окр(Мин(Документ.Сумма, НаРуки));

   ИначеЕсли Документ.Процент <> 0 Тогда

      НаРуки = 0;

      Результат = Окр(НаРуки * Процент / 100);

   КонецЕсли;

   Если Документ.Банк.Выбран() Тогда

      ПроцентУд = Документ.Банк.ПроцентУдержания;

   Иначе

      Сообщение("Не указан банк для перечисления средств!");

      Возврат;

   КонецЕсли;

   ЖР.ВвестиРасчет(Объект, ВидРасчета.БанковскиеИздержки,

                ДатаНачала, ДатаОкончания, Окр(Результат * ПроцентУд / 100));

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин