Описание встроенного языка системы 1С Предприятие


ВходитВГруппу


Определяет входимость вида расчетов в группу видов расчета.

Синтаксис:

ВходитВГруппу(<Группа>)

Англоязычный синоним:

BelongsToGroup

Параметры:

<Группа>

Группа расчетов, входимость в которую проверя­ется.

Возвращаемое значение:

Число: 1 — если вид расчета входит в группу <Группа>; 0 в противном слу­чае.

Описание:

Этот метод предназначен для определения входимости вида расчета в кон­кретную группу расчетов.

Пример:

*

// В журнале расчетов зарплаты посчитаем все начисления

// для текущего сотрудника

ЖР = СоздатьОбъект("ЖурналРасчетов.Зарплата");

// Начало и конец текущего периода журнала

НТП = ЖР.НачалоТекущегоПериода();

КТП = ЖР.КонецТекущегоПериода();

Группа = Группа.ВсеНачисления;

Всего = 0;

ЖР.ВыбратьЗаписиПоОбъекту(Объект, НТП, КТП);

Пока ЖР.ПолучитьЗапись() = 1 Цикл

   Если (ЖР.ВидРасч.ВходитВГруппу(Группа)=1) Тогда

      Всего = Всего + ЖР.Результат;

   КонецЕсли;

КонецЦикла;

// ...

*

Пока ЖрнЗарплата.ПолучитьЗапись() > 0 Цикл

   Если ЖрнЗарплата.ВидРасч = ВидРасчета.РайонныйКоэФйициент Тогда

      СуммаРайонн = СуммаРайонн + ЖрнЗарплата.Результат;

   КонецЕсли;

   Если ЖрнЗарплата.ВидРасч = ВидРасчета.СевернаяНадбавка Тогда

      СуммаСеверн = СуммаСеверн + ЖрнЗарплата.Результат;

   КонецЕсли;

   Если ЖрнЗарплата.ВидРасч.ВходитВГруппу(Группа) = 1 Тогда

      Сумма = Сумма + ЖрнЗарплата.Результат;

      Если ТипРасчета = 1 Тогда

         Дней = Дней + КалендОтп.Дней(ЖрнЗарплата.ДатаНачала,

                                      ЖрнЗарплата.ДатаОкончания);

      Иначе

         Дней = Дней + ЖрнЗарплата.Дни;

      КонецЕсли;

   КонецЕсли;

КонецЦикла;

См. также: СодержитВидРасчета




Начало  Назад  Вперед