Описание встроенного языка системы 1С Предприятие


УстановитьПредставление


Установить в форме журнала расчетов режим представления записей.

Синтаксис:

УстановитьПредставление(<Режим>, <Объект>)

Англоязычный синоним:

SetPresentation

Параметры:

<Режим>

Числовое значение — режим представления жур­нала расчетов.

<Объект>

Объект, записи которого отображаются. Если ус­танавливаемый режим — «по одному документу» (см. ниже), этот параметр должен иметь тип «до­кумент», если режим устанавливаемого представ­ления — «по одному объекту», этот параметр должен иметь тип «элемент справочника».

Возвращаемое значение:

Число: 1, если представление успешно установлено; 0 — если представление по каким-либо причинам не установлено.

Описание:

Метод УстановитьПредставление устанавливает режим вывода записей в форме журнала расчетов. Значение <Режим> может принимать следующие значения:

1.        Записи по всем объектам расчета.

2.        Записи по одному объекту расчета.

3.        Записи по одному документу-основанию.

Параметр <Объект> должен иметь тот или иной тип значения, в зависимо­сти от устанавливаемого режима. Если устанавливается режим просмотра запи­сей по одному документу, то тип значения этого параметра — «документ»; если устанавливается режим просмотра записей по одному объекту расчета (элемен­ту справочника-родителя данного журнала расчетов), то тип значения этого параметра — «элемент справочника».

Если устанавливаемый режим — просмотр записей по всем объектам расче­та, параметр <Объект> не используется.

Данный метод доступен только в контексте Модуля формы журнала расче­тов (см. «Виды программных модулей»).

Пример:

Перем СтРежим;

Перем СтОбъект;

Перем СменилиРежим;

Процедура ПоОдному(Сотрудник)

   // запомним предыдущие установки

   ПолучитьПредставление(СтРежим, СтОбъект);

   // Сменим режим

   СменилиРежим = УстановитьПредставление(2, Сотрудник);

КонецПроцедуры

Процедура Восстановить()

   Если СменилиРежим = 1 Тогда

      УстановитьПредставление(СтРежим, СтОбъект);

   КонецЕсли;

КонецПроцедуры

См. также: ПолучитьПредставление, ГраницаПросмотра




Начало  Назад  Вперед



Книжный магазин