Описание встроенного языка системы 1С Предприятие


УстановитьКартинку


Переустановить объект типа "Картинка".

Синтаксис:

УстановитьКартинку(<Объект>)

Англоязычный синоним:

SetPicture

Параметры:

<Объект>

Выражение, имеющее значение оъекта типа «Картин­ка» встроенного языка или OLE-объект типа I Picture.

Описание:

Метод УстановитьКартинку переписывает (копирует) значение источни­ка <Объект> в текущий объект. (Данный метод копирует все содержимое од­ного объекта в другой, в отличие от оператора присваивания (=), который пе­редает значение ссылки на уже существующий объект). Например:

А = СоздатьОбъект("Картинка");

В = А;

// в этом случае переменные А и В ссылаются на один и тот же объект

Рассмотрим другой вариант:

А = СоздатьОбъект("Картинка");

В = СоздатьОбъект("Картинка");

А.Загрузить("с:\BMP\Boris.bmp");

В.УстановитьКартинку(А);

// в этом случае переменные А и В ссылаются на два

// разных объекта, хотя и содержат одно и то же

Пример:

// Допустим в Форме диалога у нас есть элемент типа картинка

// с идентификатором Кино.

// Сделаем анимацию изображения в этой форме

Перем фото[5];

// создадим объекты и загрузим в них картинки

Для Н = 1 По 5 Цикл

   Фото[Н] = СоздатьОбъект("Картинка");

   Фото[Н].Загрузить("с:\BMP\Foto" + Строка(Н)+ ".bmp");

КонецЦикла;

// Теперь запустим анимацию

Для Раз = 1 По 100 Цикл

   Для Н = 1 По 5 Цикл

      Кино.УстановитьКартинку(Фото[H]);

   КонецЦикла;

КонецЦикла;





Начало  Назад  Вперед



Книжный магазин