Описание встроенного языка системы 1С Предприятие


Удалить


Удалить элемент справочника.

Синтаксис:

Удалить(<Режим>)

Англоязычный синоним:

Delete

Параметры:

<Режим>

Числовое выражение: 1 — непосредственное уда­ление; 0 — пометка на удаление. Необязательный параметр. Значение по умолчанию — 1.

Описание:

Метод Удалить удаляет (или делает пометку на удаление) текущий эле­мент или группу справочника.

Данный метод может использоваться только для объектов, созданных функцией СоздатьОбъект.

Замечание: Непосредственное удаление объекта следует применять очень ак­куратно, так как это действие может нарушить ссылочную целостность информации. Данный режим не рекомендуется использовать, если на данный объект могут быть ссылки в других объектах, например в рекви­зитах существующих документов.

Пример:

Процедура УдалениеСотрудника(Сотр)

   Спр = СоздатьОбъект("Справочник.Сотрудники");

   Если Сотр.Выбран() > 0 Тогда

      // позиционируем справочник на заданном элементе

      Спр.НайтиЭлемент(Сотр);

      Если Спр.Выбран() > 0 Тогда

         Если Вопрос("Удалять??? ", 1) = 1 Тогда

            // удаляем элемент справочника

            Спр.Удалить(1);

         КонецЕсли;

      Иначе

         Предупреждение("Некого удалять!");

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: ПометкаУдаления, СнятьПометкуУдаления




Начало  Назад  Вперед



Книжный магазин