Описание встроенного языка системы 1С Предприятие


Удалить


Удалить текущую запись.

Синтаксис:

Удалить()

Англоязычный синоним:

Del

Описание:

Метод Удалить ставит пометку «удалена» на текущую запись. Физически запись из базы данных не удаляется и может быть впоследствии восстановлена. Полное удаление записей из БД с освобождением дискового пространства, за­нятого ими, производится вызовом методов Сжать и ОчиститьФайл.

Пример:

Процедура УдалЗап()

   ДБФ.Первая();

   Пока 1 = 1 Цикл

      ДБФ.Удалить();

      ДБФ.Записать();

      Если ДБФ.Следующая() = 0 Тогда

         Возврат;

      КонецЕсли;

   КонецЦикла;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин