Описание встроенного языка системы 1С Предприятие


Удалить


Удалить периодическое значение.

Синтаксис:

Удалить()

Англоязычный синоним:

Delete

Возвращаемое значение:

Число: 1 — если вызов метода закончился успешно, 0 — если нет.

Описание:

Метод Удалить удаляет периодическое значение на заданную дату. До вы­зова данного метода атрибут ДатаЗнач должен содержать дату удаляемого пе­риодического значения..

Пример:

Процедура ЧисткаКурсов()

   Вал = СоздатьОбъект("Справочник.Валюты");

   // Позиционируем созданный объект Вал по известному коду

   Вал.НайтиПоКоду(1);

   Если Вал.Выбран() = 1 Тогда

      Доллар = Вал.ТекущийЭлемент();

   Иначе

      Предупреждение("Не найдена валюта!");

      Возврат;

   КонецЕсли;

   ПерВал = СоздатьОбъект("Периодический");

   ПерВал.ИспользоватьОбъект("Текущ_курс".Доллар);

   ПерВал.ВыбратьЗначения();

   Пока ПерВал.ПолучитьЗначение() = 1 Цикл

      Курс = ПерВал.Значение;

      ДатаКурса = ПерВал.ДатаЗнач;

      Если Курс < 1000 Тогда

         ПерВал.Удалить();

      КонецЕсли;

   КонецЦикла;

КонецПроцедуры





Начало  Назад  Вперед