Описание встроенного языка системы 1С Предприятие


Структура запросов и методика их использования - часть 4


Из приведенного выше примера можно сделать несколько важных заключе­ний:

  • при просмотре временного набора данных, вложенность циклов про­смотра должна точно повторять порядок группировок запроса (нельзя входить во вложенную группировку, не войдя в предыдущую);
  • допускается просматривать временный набор данных, опуская с некото­рого уровня все вложенные (внутренние) группировки;
  • не следует прерывать последовательность просмотра временного набора данных (например, оператором Прервать;), если вы собираетесь ис­пользовать временный набор дальше или еще раз, т. к. в таком случае те­ряется точка позиционирования во временном наборе и продолжать про­смотр невозможно;

Пример:

Пока Запрос.Группировка("Товар") = 1 Цикл

   Если (Запрос.Товар = НужныйТовар) Тогда

      Пока Запрос.Группировка("Отдел") = 1 Цикл

         Если (Запрос.Отдел = НужныйОтдел) Тогда

            Пока Запрос.Группировка("Сотрудник") = 1 Цикл

               Если (Запрос.Сотрудник = НужныйСотрудник) Тогда

                  Пока Запрос.Группировка("Док") = 1 Цикл

                     Док = Запрос.Док;

                     Если Запрос.ПрихКол <> 0 Тогда

                        Таб.ВывестиСекцию("Приход");

                     ИначеЕсли Запрос.РасхКол <> 0 Тогда

                        Приращение = Запрос.РасхКол;

                        Таб.ВывестиСекцию("Расход");

                     КонецЕсли;

                  КонецЦикла;

               КонецЕсли;

            КонецЦикла;

         КонецЕсли;

      КонецЦикла;

   КонецЕсли;

КонецЦикла;




Начало  Назад  Вперед



Книжный магазин