Описание встроенного языка системы 1С Предприятие


СтатусВозврата - часть 2


   Если Клиент.Выбран() = 0 Тогда

      Предупреждение("Запись отменена! Не задан клиент!");

      СтатусВозврата(0);

   КонецЕсли;

КонецПроцедуры

* Если в предопределенной процедуре ВводНаОсновании установить статус возврата — 0, то ввод нового документа будет отменен и форма нового до­кумента не откроется.

Процедура ВводНаОсновании(ДокОснование)

   Автор = Пользователь;

   ДокВид = ДокОснование.Вид();

   Если (ДокВид = "Счет") ИЛИ (ДокВид = "Счет_фактура")

        ИЛИ (ДокВид = "РасходнаяКредит") ИЛИ (ДокВид = РасходнаяРеализ") Тогда

      Автор = Пользователь;

      ДокВид = ДокОснование.Вид();

      Фирма = ДокОснование.Фирма;

      Клиент = ДокОснование.Клиент;

      Основание = ДокВид + " № " + ДокОснование.НомерДок;

      Сумма = ДокОснование.Итог("Сумма");

      НДС = ДокОснование.Итог("НДС");

   Иначе

      Предупреждение("Недопустимый вид документа основания!");

      СтатусВозврата(0);

   КонецЕсли;

КонецПроцедуры

См. также: «Системные предопределенные процедуры»




Начало  Назад  Вперед