Описание встроенного языка системы 1С Предприятие


Следующая


Перейти на следующую запись.

Синтаксис:

Следующая()

Англоязычный синоним:

Next

Возвращаемое значение:

Число: 1 — получена следующая запись; 0 — следующая запись не найдена.

Описание:

Метод Следующая предназначен для позиционирования объекта на сле­дующую запись. В зависимости от того, установлен ли текущий индекс, пози­ционирование происходит либо в порядке возрастания физического номера записи, либо в порядке возрастания значения выражения текущего индекса (если индекс создавался с установленным флагом "Убывание", то в порядке убавания).

Пример:

// Обнуляет значения всех полей всех существующих записей

Процедура ОчистЗап() ДБФ.Первая();

   Пока 1 = 1 Цикл

      ДБФ.Очистить();

      ДБФ.Записать();

      Если ДБФ.Следующая() = 0 Тогда

         Возврат;

      КонецЕсли;

   КонецЦикла;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин