Описание встроенного языка системы 1С Предприятие


Рассчитана


Признак того, что запись рассчитана.

Синтаксис:

Рассчитана

Англоязычный синоним:

Calculated

Описание:

Атрибут типа «число», принимает два значения: 1 — для рассчитанных за­писей журнала расчетов и 0 — для нерассчитанных записей.

Запись журнала расчетов становится рассчитанной в результате удачного выполнения одной из соответствующих команд меню «Действия» или при вы­полнении методов журнала расчетов Рассчитать, ВыпролнитьРасчет.

Атрибут Рассчитана предназначен только для чтения.

Пример:

// Перед выводом отчета проверим, все ли записи рассчитаны

ЖрнЗарплата = СоздатьОбъект("ЖурналРасчетов.Зарплата");

ЖрнЗарплата.ВыбратьПериодПоОбъекту(Сотрудник, ДатаОтчета);

// признак нерассчитанности

ПлохоДело=0;

Пока ЖрнЗарплата.ПолучитьЗапись() = 1 Цикл

   Если ЖрнЗарплата.Рассчитана = 0 Тогда

      ПолохоДело = 1;

      Прервать;

   КонецЕсли;

КонецЦикла;

Если ПлохоДело = 1 Тогда

   Предупреждение("Не проведен полный расчет сотрудника!

                   | Формирование отчета невозможно");

   Возврат;

КонецЕсли;

// продолжим формирование документа

См. также: Исправлена, Фиксирована




Начало  Назад  Вперед



Книжный магазин