Описание встроенного языка системы 1С Предприятие


Проведен


Возвратить флаг проводки документа.

Синтаксис:

Проведен()

Англоязычный синоним:

IsTransacted

Возвращаемое значение:

Числовое значение: 1 — если документ проведен, 0 — если документ не про­веден.

Описание:

Метод Проведен позволяет проверить сам факт проведения документа.

Пример:

Процедура ПолучитьПроведенные()

   Док = СоздатьОбъект("Документ");

   // Откроем выборку документов

   Док.ВыбратьДокументы(ДатаНачала, ДатаКонца);

   // Цикл выбора документов

   Пока Док.ПолучитьДокумент() > 0 Цикл

      Если Док.Проведен() > 0 Тогда

         // для проведенных документов выведем сообщение

         Сообщить(Строка(Док.Вид())+" № "+Док.НомерДок+" от "+Док.ДатаДок);

      КонецЕсли;

   КонецЦикла;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин