Описание встроенного языка системы 1С Предприятие


ПриЗаписиКонстанты


Предопределенная процедура при записи значения константы.

Синтаксис:

ПриЗаписиКонстанты(<ИмяКонстанты>, <3начение>)

Англоязычный синоним:

OnWriteConst

Параметры:

<ИмяКонстанты>

Название константы, как оно задано в конфигура­торе (например, "СкладПоУмолчанию").

<3начение>

Новое значение константы.

Описание:

Вызов предопределенной процедуры ПриЗаписиКонстанты производится системой 1С:Предприятие неявно при интерактивной записи значения кон­станты. Если в данной предопределенной процедуре установить статус возврата — 0 (например, если данное значение константы запрещено), то запись кон­станты не будет выполнена.

Данная предопределенная процедура может располагаться только в гло­бальном программном модуле.

Пример:

Процедура ПриЗаписиКонстанты(ИмяКонстанты, Значение)

   Если ИмяКонстанты = "ТекущийПрефикс" Тогда

      Если НазваниеНабораПрав() = "Продавец" Тогда

         Предупреждение("У вас нет права менять префикс!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин