Описание встроенного языка системы 1С Предприятие


ПриЗаписи


Предопределенная процедура при записи элемента справочника.

Синтаксис:

ПриЗаписи(<СписокПериодРекв>)

Англоязычный синоним:

OnWrite

Параметры:

<СписокПериодРекв>

Строковое значение — список разделенных за­пятыми изменяемых периодических реквизитов справочника. В данный параметр система 1С:Предприятие передает перечень периодиче­ских реквизитов, которые были интерактивно выбраны пользователем для обновления в окне диалога выбора. В теле процедуры значение данного параметра может быть изменено, что позволяет в данной процедуре непосредственно управлять списком записываемых значений периодических реквизитов.

Описание:

Вызов предопределенной процедуры ПриЗаписи производится системой 1С:Предприятие при интерактивной записи элемента справочника. Если в дан­ной предопределенной процедуре установить статус возврата — 0 (например, если данному пользователю нельзя изменять некоторые элементы справочни­ка), то запись элемента справочника не будет выполнена.

Данная предопределенная процедура может располагаться в следующих программных модулях: Модуль формы элемента справочника, Модуль формы группы справочника, Модуль формы списка справочника (см. Виды программ­ных модулей).

Пример:

Процедура ПриЗаписи (СписокРекв)

   Если НазваниеНабораПрав() = "Продавец" Тогда

      Если ТекущийЭлемент() = Константа.НашаФирма Тогда

         Предупреждение("У вас нет права менять реквизиты!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин