Описание встроенного языка системы 1С Предприятие


ПриЗаписи


Предопределенная процедура при записи строки списка справочника.

Синтаксис:

ПриЗаписи(<СписокПериодРекв>)

Англоязычный синоним:

OnWrite

Параметры:

<СписокПериодРекв>

Строковое значение — список разделенных запятыми изменяемых периодических рекви­зитов справочника. В данный параметр систе­ма 1С:Предприятие передает перечень перио­дических реквизитов, которые были интерак­тивно выбраны пользователем для обновления в окне диалога выбора.

Описание:

Вызов предопределенной процедуры ПриЗаписи производится системой 1С:Предприятие при интерактивной записи строки списка справочника. Если в данной предопределенной процедуре установить статус возврата — 0 (напри­мер, если данному пользователю нельзя изменять некоторые элементы спра­вочника), то запись строки списка справочника не будет выполнена.

Формальный параметр <СписокПериодРекв> используется в теле проце­дуры для обработки события интерактивной записи строки списка справочни­ка.

Данная предопределенная процедура может располагаться в следующих программных модулях: Модуль формы элемента справочника, Модуль формы группы справочника, Модуль формы списка справочника, Модуль формы спи­ска справочника (см. Виды программных модулей).

Пример:

Процедура ПриЗаписи (СписокРекв)

   Если НазваниеНабораПрав() = "Продавец" Тогда

      Если ТекущийЭлемент() = Константа.НашаФирма Тогда

         Предупреждение("У вас нет права менять реквизиты!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин