Описание встроенного языка системы 1С Предприятие


ПриВыбореЗакладки


Предопределенная процедура смены закладки формы.

Синтаксис:

ПриВыбореЗакладки(<НомерЗакладки>, <Значение3акладки>)

Англоязычный синоним:

OnTabCtrlPosChanged

Параметры:

<НомерЗакладки>

Числовое значение — номер выбранной за­кладки формы.

<Значение3акладки>

Значение выбранной закладки формы.

Описание:

Вызов предопределенной процедуры ПриВыбореЗакладки производится в системе 1С:Предприятие неявно в момент интерактивного выбора пользовате­лем закладки в форме. При вызове процедуры, система подставляет фактиче­ские значения параметров, характеризующие выбранную закладку.

Параметры <НомерЗакладки> и <Значение3акладки> используется в теле процедуры для обработки передаваемого системой события смены заклад­ки формы.

Данная предопределенная процедура может располагаться только в про­граммном модуле формы.

Пример:

Процедура ЗакладкаОбщиеВидимость(ФлагВидимости)

   Форма.Название.Видимость(ФлагВидимости);

   Форма.Наименование.Видимость(ФлагВидимости);

   Форма.Код.Видимость(ФлагВидимости);

   Форма.Статус.Видимость(ФлагВидимости);

   Форма.Адрес.Видимость(ФлагВидимости);

   Форма.Телефон.Видимость(ФлагВидимости);

   Активизировать("Наименование", 0);

КонецПроцедуры

Процедура ЗакладкаЗаметкиВидимость(ФлагВидимости)

   Форма.Заметки.Видимость(ФлагВидимости);

   Активизировать("Заметки", 0);

КонецПроцедуры

Процедура ПриВыбореЗакладки(НомерЗакладки, ЗначениеЗакладки)

   Если Значение3акладки = 1 Тогда

      Закладка.Заметки.Видимость(0);

      Закладка.Общие.Видимость(1);

   ИначеЕсли ЗначениеЗакладки = 2 Тогда

      Закладка.Общие.Видимость(0);

      Закладка.Заметки.Видимость(1);

   КонецЕсли;

КонецПроцедуры

См. также: ИспользоватьЗакладки, Закладки, СтатусВозврата




Начало  Назад  Вперед



Книжный магазин