Описание встроенного языка системы 1С Предприятие


ПриВыбореВладельца


Предопределенная процедура выбора владельца подчиненного спра­вочника.

Синтаксис:

ПриВыбореВладельца(<Элемент>)

Англоязычный синоним:

OnSetOwner

Параметры:

<Элемент>

Значение элемента справочника, который интерактивно устанавливается в качестве владельца подчиненного спра­вочника.

Описание:

Вызов предопределенной процедуры ПриВыбореВладельца производится в системе ЮПредприятие при интерактивном выборе владельца подчиненного справочника (при интерактивной смене владельца, т. е. смене позиции в спра­вочнике-владельце, которая приводит к смене отображаемых в подчиненном справочнике элементов). Если в данной предопределенной процедуре устано­вить статус возврата — 0, то выбор владельца подчиненного справочника не будет произведен.

Данная предопределенная процедура может располагаться только в Модуле формы списка справочника (см. «Виды программных модулей»).

Пример:

Процедура ПриВыбореВладельца(Владелец)

   Если НазваниеНабораПрав() = "Продавец" Тогда

      Если Владелец = ЗапрещенныйВладелец Тогда

         Предупреждение("Нельзя просматривать эти элементы!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин