Описание встроенного языка системы 1С Предприятие


ПриВыбореВладельца


Предопределенная процедура выбора элемента справочника по кото­рому будут выведены расчеты.

Синтаксис:

ПриВыбореВладельца(<Владелед>)

Англоязычный синоним:

OnSetOwner

Параметры:

<Владелец>

Значение устанавливаемого владельца — т. е. элемент спра­вочника по которому будут выведены расчеты.

Описание:

Вызов предопределенной процедуры ПриВыбореВладельца производится в системе 1С:Предприятие при интерактивном выборе владельца журнала рас­четов (при интерактивной смене владельца, т. е. смене позиции в справочнике-владельце, которая приводит к смене отображаемых расчетов). Если в данной предопределенной процедуре установить статус возврата — 0, то выбор вла­дельца не будет произведен.

Внимание! Процедура выполняется только в том случае, когда журнал расче­тов выводится «по объекту», т. е. в нем отображаются записи по одному объекту расчета. Вызов процедуры происходит в момент смены текущего элемента в «главном» справочнике, для которого создан журнал расчетов.

Данная предопределенная процедура может располагаться только в модуле формы журнала расчетов.

Пример:

Процедура ПриВыбореВладельца(Владелец)

   Если НазваниеНабораПрав() = "Продавец" Тогда

      Если Владелец = ЗапрещенныйВладелец Тогда

         Предупреждение("Нельзя изменять объект расчетов;", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед