Описание встроенного языка системы 1С Предприятие


ПриВыбореРодителя


Предопределенная процедура выбора родительской группы справоч­ника.

Синтаксис:

ПриВыбореРодителя(<Элемент>)

Англоязычный синоним:

OnSetParent

Параметры:

<Элемент>

Значение элемента справочника, который интерак­тивно устанавливается в качестве родителя.

Описание:

Вызов предопределенной процедуры ПриВыбореРодителя производится в системе 1С:Предприятие при интерактивной смене родительской группы спра­вочника (выбор следующего или предыдущего уровня). Если в данной предо­пределенной процедуре установить статус возврата — 0, то выбор родительской группы не будет произведен.

Данная предопределенная процедура может располагаться только в Модуле формы списка справочника (см. «Виды программных модулей»).

Пример:

Процедура ПриВыбореРодителя(Родитель)

   Если НазваниеНабораПрав() = "Продавец" Тогда

      Если Родитель = ЗапрещеннаяГруппа Тогда

         Предупреждение("Вам запрещено просматривать эту группу!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин