Описание встроенного языка системы 1С Предприятие


ПриВыбореРодителя


Предопределенная процедура выбора родительской группы счета.

Синтаксис:

ПриВыбореРодителя(<Счет>)

Англоязычный синоним:

OnSetParent

Параметры:

<Счет>

Значение счета, который интерактивно установ­лен в качестве родителя.

Описание:

Вызов предопределенной процедуры ПриВыборе Родителя производится в системе 1С:Предприятие при интерактивной смене родительской группы счета (выбор следующего или предыдущего уровня). Если в данной предопределен­ной процедуре установить статус возврата — 0, то выбор родительской группы не будет произведен.

Данная предопределенная процедура может располагаться только в Модуле формы списка счетов.

Пример:

Процедура ПриВыбореРодителя(Родитель)

   Если НазваниеНабораПрав() = "Продавец" Тогда

      Если Родитель = ЗапрещеннаяГруппа Тогда

         Предупреждение("Вам запрещено изменять счет!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин