Описание встроенного языка системы 1С Предприятие


ПриУстановкеПредставления


Предопределенная процедура, вызываемая при установке режима представления журнала расчетов (по всем объектам расчетов, по од­ному объекту расчета, по одному документу расчета).

Синтаксис:

ПриУстановкеПредставления(<Режим>}

Англоязычный синоним:

OnSetPresentation

Параметры:

<Режим>

Числовое значение — режим представления записей журнала расчетов, устанавливаемый пользователем.

Описание:

Вызов этой предопределенной процедуры производится системой 1С:Предприятие неявно при интерактивной попытке установить другой режим представления записей в журнале расчетов. Если в данной предопределенной процедуре установить статус возврата 0 (например, если данному пользова­телю нельзя использовать определенный режим), установка не будет выполне­на.

Параметр <Режим> может принимать следующие значения:

1.        Записи по всем объектам расчета.

2.        Записи по одному объекту расчета.

3.        Записи по одному документу-основанию.

Данная предопределенная процедура может располагаться только в модуле формы журнала расчетов.

Пример:

Процедура ПриУстановкеПредставления(Режим)

   Если НазваниеНабораПрав() = "Расчетчик" Тогда

      Если (Режим = 1) Тогда

         Предупреждение("Недостаточно прав!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата, УстановитьПредставление





Начало  Назад  Вперед