Описание встроенного языка системы 1С Предприятие


ПриУстановкеОтбора


Предопределенная процедура при установке отбора.

Синтаксис:

ПриУстановкеОтбора(<ИмяРеквизОтбора>, <3начение>)

Англоязычный синоним:

OnSetSelectInJournal

Параметры:

<ИмяРеквизОтбора>

Строковое значение — название общего рекви­зита документа (как оно задано в конфигура­торе), по которому производится отбор (на­пример, "Автор").

<3начение>

Значение реквизита отбора. Допустим, у документов существует общий реквизит "Автор", по которому решено про­вести отбор, значит в этом параметре будет передано конкретное значение этого реквизи­та, по которому решено провести отбор (на­пример, "Сидоров И.А.").

Описание:

Вызов предопределенной процедуры ПриУстановкеОтбора производится самой системой 1С:Предприятие неявно при интерактивной попытке устано­вить отбор документов в журнале. Если в данной предопределенной процедуре установить статус возврата — 0 (например, если данному пользователю нельзя устанавливать данное значение отбора документов), установка не будет выпол­нена.

Данная предопределенная процедура может располагаться в глобальном программном модуле и модуле формы журнала. Если данная процедура при­сутствует в модуле формы соответствующего журнала, то будет вызвана она, если нет, то будет вызвана процедура из глобального модуля.

Пример:

Процедура ПриУстановкеОтбора(ИмяОтбора, ЗначОтбора)

   Если НазваниеНабораПрав() = "Продавец" Тогда

      Если (Имя0тбора = "Автор") И (ЗначОтбора <> ТекущПользователь) Тогда

         Предупреждение("У вас нет права просматривать чужие документы!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин