Описание встроенного языка системы 1С Предприятие


ПриУстановкеОтбора


Предопределенная процедура, вызываемая при установке отбора в форме журнала расчетов.

Синтаксис:

ПриУстановкеОтбора(<ИмяОтбора>, <ЗначениеОтбора>)

Англоязычный синоним:

OnSetSelection

Параметры:

<ИмяОтбора>

Строковое значение. Наименование графы отбора, которая выбрана пользователем при интерактивной установке отбора.

<ЗначениеОтбора>

Значение отбора, которое выбрано пользова­телем при интерактивной установке отбора.

Описание:

Вызов предопределенной процедуры ПриУстановкеОтбора производится системой 1С:Предприятие неявно при интерактивной попытке установить от­бор записей в журнале расчетов. Если в данной предопределенной процедуре установить статус возврата — 0 (например, если данному пользователю нельзя устанавливать данное значение отбора документов), установка не будет выпол­нена.

Данная предопределенная процедура может располагаться только в модуле формы журнала расчетов.

Пример:

Процедура ПриУстановкеОтбора(ИмяОтбора, ЗначОтбора)

   Если НазваниеНабораПрав() = "Расчетчик" Тогда

      Если (ИмяОтбора = "Владелец") И (ЗначОтбора <> ТекущийРасчетчик) Тогда

         Предупреждение("Недостаточно прав!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата, УстановитьОтбор, ПолучитьОтбор




Начало  Назад  Вперед