Описание встроенного языка системы 1С Предприятие


ПриУстановкеОтбора


Предопределенная процедура при установке отбора в журнале операций.

Синтаксис:

ПриУстановкеОтбора(<ИмяОт6ора>, <Значение>)

Англоязычный синоним:

OnSetSelectInJournal

Параметры:

<ИмяОтбора>

Строковое выражение — имя отбора.

<ЗначениеОтбора>

Значение отбора.

Описание:

Вызов предопределенной процедуры ПриУстановкеОтбора производится системой 1С:Предприятие неявно при интерактивной попытке установить от­бор в журнале операций.

Если в данной предопределенной процедуре установлен статус возврата 0 (например, если данному пользователю нельзя устанавливать данное значение отбора операций), установка отбора не будет выполнена.

Данная предопределенная процедура может располагаться в модуле формы журнала операций и в глобальном программном модуле. Если данная процеду­ра присутствует в модуле формы журнала операций, то будет вызвана она, если нет, то будет вызвана процедура из глобального модуля.

Пример:

Процедура ПриУстановкеОтбора(ИмяОтбора, ЗначОтбора)

   Если НазваниеНабораПрав() = "Оператор" Тогда

      Если (ИмяОтбора = "Автор") И (ЗначОтбораоТекПольз) Тогда

         Предупреждение("У вас нет права просматривать чужие Операции!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин