Описание встроенного языка системы 1С Предприятие


ПриУстановкеГраницыПросмотра


Предопределенная процедура, вызываемая при установке границы (по периоду регистрации записи) просматриваемых в журнале расче­тов записей.

Синтаксис:

ПриУстановкеГраницыПросмотра(<Период>)

Англоязычный синоним:

OnSetViewBound

Параметры:

<Период>

Значение типа «Период журнала расчетов». Период, устанавливаемый пользователем как граница просмотра записей.

Описание:

Вызов этой предопределенной процедуры производится системой 1С:Предприятие неявно при интерактивной попытке установить другую грани­цу просмотра записей в журнале расчетов. Если в данной предопределенной процедуре установить статус возврата — 0 (например, если данному пользова­телю нельзя просматривать расчеты определенной «давности»), установка не будет выполнена.

Данная предопределенная процедура может располагаться только в модуле формы журнала расчетов.

Пример:

Процедура ПриУстановкеГраницыПросмотра(Период)

   Если НазваниеНабораПрав() = "Расчетчик" Тогда

      ТП = ТекущийПериод();

      // не позволим смотреть более чем на три периода назад

      МинПер = ТП.ПрибавитьПериод(-3);

      Если (Период.ДатаНачала<МинПер.ДатаНачала) Тогда

         Предупреждение("Недостаточно прав 1", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата, ГраницаПросмотра




Начало  Назад  Вперед



Книжный магазин