Описание встроенного языка системы 1С Предприятие


ПриУдаленииЭлемента


Предопределенная процедура при удалении элемента справочника и при отмене пометки на удаление.

Синтаксис:

ПриУдаленииЭлемента(<УдалЭлем>, <Режим>)

Англоязычный синоним:

OnDeleteItem

Параметры:

<УдалЭлем>

Значение удаляемого элемента справочни­ка.

<Режим>

Значение флага непосредственного удале­ния: 1 — непосредственное удаление; 0 — пометка на удаление.

Описание:

Вызов предопределенной процедуры ПриУдаленииЭлемента производится системой 1С:Предприятие неявно при интерактивном удалении элемента спра­вочника и в случае отмены пометки на удаление. В этом случае, условия вызо­ва можно узнать методом ПометкаУдаления элемента справочника. Если в данной предопределенной процедуре установить статус возврата — 0 (напри­мер, если нарушается ссылочная целостность системы), то удаление элемента справочника не будет выполнено.

Данная предопределенная процедура может располагаться только в гло­бальном программном модуле.

Пример:

Процедура ПриУдаленииЭлемента(Элем, Реж)

   Если НазваниеНабораПрав() = "Продавец" Тогда

      Если (Элем.Вид() = "Товар") И (Реж = 1) Тогда

         Предупреждение("У вас нет права удалять Товар!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин