Описание встроенного языка системы 1С Предприятие


ПриУдаленииИстории


Предопределенная процедура при удалении в окне «История» значе­ния периодического реквизита элемента справочника или константы.

Синтаксис:

ПриУдаленииИстории(<ТипОбъекта>, <Объект>, <3начение>, <ДатаИстории>)

Англоязычный синоним:

OnDeleteHistory

Параметры:

<ТипОбъекта>

Название периодического объекта конфигурации, как оно задано в конфигураторе (например, "Справочник.Валюты.ТекущийКурс" или " Константа. ИмяДиректора"). Строковое назва­ние агрегатного типа данных может передаваться системой в русском или англоязычном написании (Справочник или Reference, Константа или Const) — в зависимости от установки флага ос­новного языка системы (см. ОсновнойЯзык).

<Объект>

Элемент справочника, для которого выполняется изменение периодического реквизита. Имеет смысл только для периодических реквизитов справочни­ков, а не для констант.

<3начение>

Значение периодической записи.

<ДатаИстории>

Дата периодической записи.

Описание:

Вызов предопределенной процедуры ПриУдаленииИстории производится системой 1С:Предприятие неявно при интерактивном удалении периодической записи в окне «История». Если в данной предопределенной процедуре устано­вить статус возврата — 0 (например, если данному пользователю запрещено изменение периодических реквизитов), то удаления периодического значения не будет выполнено.

Данная предопределенная процедура может располагаться только в гло­бальном программном модуле.

Пример:

Процедура ПриУдаленииИстории(ТипОб, Об, Значен, ДатаИстор)

   Если НазваниеНабораПрав() = "Продавец" Тогда

      Если (ТипОб = "Справочник.Валюты.ТекКурс") И

           (Об=Константа.ОсновнаяВалюта) И (ДатаИстор < РабочаяДата() - 7) Тогда

         // Удаляется курс для валюты, которая записана в Константе

         Предупреждение("У вас нет права удалять прошлый курс!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата, ОсновнойЯзык




Начало  Назад  Вперед



Книжный магазин