Описание встроенного языка системы 1С Предприятие


ПриУдаленииДокумента


Предопределенная процедура при удалении документа и при отмене пометки на удаление.

Синтаксис:

ПриУдаленииДокумента(<УдалДокум>, <Режим>)

Англоязычный синоним:

OnDeleteDoc

Параметры:

<УдалДокум>

Значение удаляемого документа.

<Режим>

Значение флага непосредственного удаления: 1 — непосредственное уда­ление; 0 — пометка на удаление.

Описание:

Вызов предопределенной процедуры ПриУдаленииДокумента производит­ся системой 1С:Предприятие неявно при интерактивном удалении документа и в случае отмены пометки на удаление. В этом случае, условия вызова можно узнать методом ПометкаУдаления документа. Если в данной предопределен­ной процедуре установить статус возврата — 0 (например, если не истек срок хранения документа), то удаление документа не будет выполнено.

Данная предопределенная процедура может располагаться только в гло­бальном программном модуле.

Пример:

Процедура ПриУдаленииДокумента(Док, Реж)

   Если НазваниеНабораПрав() = "Продавец" Тогда

      Если (Док.Вид() = "РасходнаяНакл") И (Реж = 1) Тогда

         Предупреждение("У вас нет права удалять накладную!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин