Описание встроенного языка системы 1С Предприятие


ПриСменеРасчетногоПериода


Предопределенная процедура, вызываемая при смене текущего рас­четного периода журнала расчетов.

Синтаксис:

ПриСменеРасчетногоПериода(<ЖурналРасчетов>, <Период>)

Англоязычный синоним:

OnРег1odChange

Параметры:

<ЖурналРасчетов>

Журнал расчетов, период которого изменяет­ся (агрегатный объект типа «ЖурналРасче-тов»).

<Период>

Устанавливаемый расчетный период (значе­ние типа «ПериодРасчета»).

Описание:

Вызов предопределенной процедуры ПриСменеРасчетногоПериода на исполнение производится системой 1C:Предприятие неявно при попытке сме­ны текущего расчетного периода любого журнала расчетов. Если в данной пре­допределенной процедуре установить статус возврата — 0, то текущий расчет­ный период не будет изменен.

Данная предопределенная процедура может располагаться только в гло­бальном программном модуле.

Пример:

Процедура ПриСменеРасчетногоПериода(ЖР, Период)

   Если ЖР.Вид() = "Зарплата" Тогда

      Предупреждение("Это смена текущего расчетного периода для журнала

                          | Зарплата");

   КонецЕсли;

   Если Период.ДатаНачала <= ЖР.НачалоТекущегоПериода Тогда

      //не позволяем откатывать период назад

      СтатусВозврата(0);

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин