Описание встроенного языка системы 1С Предприятие


ПриРасчете


Предопределенная процедура, вызываемая из формы журнала расче­тов при расчете записи журнала расчетов, всего объекта расчета или всех записей по документу.

Синтаксис:

ПриРасчете(<ОбъектРасчета>)

Англоязычный синоним:

OnCalculating

Параметры:

<ОбъектРасчета>

Запись журнала расчетов или элемент спра­вочника, являющийся объектом расчета, или документ, записи которого рассчитываются. Что в данный момент передается системой при вызове процедуры — зависит от выпол­няемого действия: расчет одной записи, рас­чет объекта или расчет документа.

Описание:

Вызов предопределенной процедуры ПриРасчете на исполнение произво­дится системой 1С:Предприятие неявно при выполнении одной из трех команд «Рассчитать запись», «РассчитатьОбъект» или «Рассчитать документ» меню «Действия» журнала расчетов. Если в данной предопределенной процедуре установить статус возврата — 0, то расчет проводиться не будет.

Данная предопределенная процедура может располагаться только в модуле формы журнала расчетов.

Пример:

Процедура ПриРасчете(Объект)

   // определим, что считаем?

   Если ТипЗначения(Объект) = 12 Тогда

      // имеем дело с документом

      Если Объект.Автор <> Расчетчик Тогда

         // если автор данного документа не текущий расчетчик, то

         // запретим расчет чужого документа!

         СтатусВозврата(0);

      КонецЕсли;

   ИначеЕсли ТипЗначения(Объект) = 11 Тогда

      // а это — элемент справочника

      Если Объект.Владелец <> Расчетчик Тогда

         // если рассчитываемый объект лежит в папке текущего расчетчика

         // считать можно иначе — нет

         СтатусВозврата(0);

      КонецЕсли;

   Иначе

      // иначе — считаем одну запись

      Если (Объект.Документ.Автор <> Расчетчик) ИЛИ

             (Объект.Объект.Владелец <> Расчетчик) Тогда

         //не дадим считать запись чужого документа или объекта

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата




Начало  Назад  Вперед



Книжный магазин