Описание встроенного языка системы 1С Предприятие


ПриОткрытииИстории


Предопределенная процедура при открытии окна «История» значе­ния периодического реквизита элемента справочника или константы.

Синтаксис:

ПриОткрытииИстории(<ТипОбъекта>, <Объект>, <ТолькоПросмотр>)

Англоязычный синоним:

OnOpenHistory

Параметры:

<ТипОбъекта>

Название периодического объекта конфигурации, как оно задано в конфигураторе (например, "Справочник.Валюты.ТекущийКурс" или " Константа. ИмяДиректора"). Строковое назва­ние агрегатного типа данных может передаваться системой в русском или англоязычном написании (Справочник или Reference, Константа или Const) — в зависимости от установки флага ос­новного языка системы (см. ОсновнойЯзык).

<Объект>

Элемент справочника, для которого выполняется открытие окна истории периодического реквизита. Имеет смысл только для периодических реквизитов справочников, а не для констант.

<ТолькоПросмотр>

Флаг установки режима "только просмотр" для окна истории значения. Если значение этого пара­метра установить в 1 (в предопределенной проце­дуре), то окно истории будет открыто только для чтения. Установка значения в 0 — введет режим по умолчанию (определенный правами). Уже открытое окно истории соответствующим образом изменит режим (если это случай, когда процедура обрабаты­вает не открытие окна, а смену отображаемого объ­екта). Значение по умолчанию — 0.

Описание:

Вызов предопределенной процедуры ПриОткрытииИстории производится системой 1С:Предприятие неявно при при открытии окна «История» значения периодического реквизита элемента справочника или константы. Если в данной предопределенной процедуре установить статус возврата — 0 (например, если данному пользователю запрещено изменение периодических реквизитов), то запись нового периодического значения не будет выполнена.

Данная предопределенная процедура может располагаться только в гло­бальном программном модуле.

Пример:

Процедура ПриОткрытииИстории(ТипОб, Об, ФлагРежима)

   Если НазваниеНабораПрав() = "Продавец" Тогда

      Если (ТипОб = "Справочник.Валюты.ТекКурс") И

           (Об = Константа.ОсновнаяВалюта)) Тогда

         Предупреждение("У вас нет права просматривать историю курса!", 2);

         СтатусВозврата(0);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: СтатусВозврата, ОсновнойЯзык




Начало  Назад  Вперед



Книжный магазин