Описание встроенного языка системы 1С Предприятие


ПриоритетВытеснения


Приоритет вытеснения вида расчета.

Синтаксис:

ПриоритетВытеснения

Англоязычный синоним:

ReplacePriority

Описание:

Атрибут типа «число». Представляет собой число, соответствующее приори­тету вытеснения вида расчета, заданному при конфигурировании. Система ис­пользует приоритет вытеснения при разрешении ситуации, когда полностью или частично пересекаются периоды действия видов расчета. Например, когда метод журнала расчетов ВвестиРасчет вводит расчет в «занятый» временной интервал.

Для невытесняющих видов расчета значение этого атрибута равно нулю.

Замечание. Атрибут сохранен для поддержания совместимости с предыдущи­ми версиями программы. Вместо использования данного атрибута реко­мендуется использовать методы ВытесняетВидРасчета и ВытесняетсяВидомРасчета.

Пример:

*

ВР01 = ВидРасчета.ПоОкладу;

Сообщить("Это расчет "+ВР01.Наименование+" с очередностью "+ВР01.Очередность);

*

Процедура ПровестиДокумент()

   ЖрнЗарплата.ВыбратьЗаписиПоОбъекту(Сотрудник, Начало, Окончание};

   Можно = 1;

   Пока ЖрнЗарплата.ПолучитьЗапись() > 0 Цикл

      Если ЖрнЗарплата.ВидРасч.ПриоритетВытеснения >=

           ВидРасчета.ОплатаБЛ.ПриоритетВытеснения Тогда

         Можно = 0;

      КонецЕсли;

   КонецЦикла;

   Если Начало > Окончание Тогда

      Можно = 0;

   КонецЕсли;

   Если Можно = 1 Тогда

      ЖрнЗарплата.ВвестиРасчет(Сотрудник, ВидРасчета.ОплатаБЛ, Начало,

                    Окончание, 0);

      Если Начало < ЖрнЗарплата.НачалоТекущегоПериода() Тогда

         Перерасчет(ГруппаРасчетов.ПересчДляБЛ, Сотрудник, ТекущийДокумент(),

                     Начало, Окончание);

      КонецЕсли;

   Иначе

      Предупреждение("Некорректный больничный лист!

                | Проверьте и исправьте даты начала и окончания.

                | После этого закройте документ, повторно откройте

                | и проведите его");

      НеПроводитьДокумент();

   КонецЕсли;

КонецПроцедуры

См. также: методы журнала расчетов ВвестиРасчет, ЗаписатьРасчет




Начало  Назад  Вперед